summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-19 17:19:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-19 17:19:29 +0000
commit6b6c8fd10008c15e982dc2c5668eb6d5ab4307d7 (patch)
tree3e71510405781c6cf015d40addcf77c4a79fd52a /include
parent062456ec4c5ad06f29598e3332a2d26fc0391cb1 (diff)
downloadmaster-31e0f0ae-6b6c8fd10008c15e982dc2c5668eb6d5ab4307d7.tar.gz
master-31e0f0ae-6b6c8fd10008c15e982dc2c5668eb6d5ab4307d7.tar.bz2
master-31e0f0ae-6b6c8fd10008c15e982dc2c5668eb6d5ab4307d7.zip
fix potential rootfs owner/group mismatch (tgz root only, patch from #4562)
SVN-Revision: 14569
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 2b239ca3a3..7de2d6346e 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -62,7 +62,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
define Image/mkfs/tgz
- $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
endef
endif