summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-13 21:36:58 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-13 21:36:58 +0000
commit668fd620805f95d16f8a41eba33317c71ba61f20 (patch)
tree911a094029ddff2180e6da3d138be73f75e0cc22 /include
parente438c665db5e53b8a6f8f0eb4c7dcb6c735e2c78 (diff)
downloadmaster-31e0f0ae-668fd620805f95d16f8a41eba33317c71ba61f20.tar.gz
master-31e0f0ae-668fd620805f95d16f8a41eba33317c71ba61f20.tar.bz2
master-31e0f0ae-668fd620805f95d16f8a41eba33317c71ba61f20.zip
don't use lzma/jffs2 on <2.6.33, set lzma/jffs2 as default for >=2.6.33. switch verbose mode on compresor statistics.
SVN-Revision: 20844
Diffstat (limited to 'include')
-rw-r--r--include/image.mk26
1 files changed, 20 insertions, 6 deletions
diff --git a/include/image.mk b/include/image.mk
index f2791212bb..34453f460a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -18,17 +18,31 @@ KDIR=$(KERNEL_BUILD_DIR)
IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
ifneq ($(CONFIG_BIG_ENDIAN),y)
-JFFS2OPTS := --pad --little-endian --squash
+JFFS2OPTS := --pad --little-endian --squash -v
SQUASHFS_OPTS := -le
else
-JFFS2OPTS := --pad --big-endian --squash
+JFFS2OPTS := --pad --big-endian --squash -v
SQUASHFS_OPTS := -be
endif
-JFFS2OPTS+= $(if $(CONFIG_KERNEL_JFFS2_RTIME)$(LINUX_2_4),-X,-x) rtime
-JFFS2OPTS+= $(if $(CONFIG_KERNEL_JFFS2_ZLIB),-X,-x) zlib
-JFFS2OPTS+= $(if $(CONFIG_KERNEL_JFFS2_LZMA)$(LINUX_2_4),-X,-x) lzma
-JFFS2OPTS+= $(JFFS2COMPR) --compression-mode=size
+ifeq ($(CONFIG_JFFS2_RTIME),y)
+JFFS2OPTS+= -X rtime
+endif
+ifeq ($(CONFIG_JFFS2_ZLIB),y)
+JFFS2OPTS+= -X zlib
+endif
+ifeq ($(CONFIG_JFFS2_LZMA),y)
+JFFS2OPTS+= -X lzma --compression-mode=size
+endif
+ifneq ($(CONFIG_JFFS2_RTIME),y)
+JFFS2OPTS+= -x rtime
+endif
+ifneq ($(CONFIG_JFFS2_ZLIB),y)
+JFFS2OPTS+= -x zlib
+endif
+ifneq ($(CONFIG_JFFS2_LZMA),y)
+JFFS2OPTS+= -x lzma
+endif
ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
USE_SQUASHFS3 := y