summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 04:10:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 04:10:01 +0000
commit5a9cdef5499b091c8c5c35f7cdc822eb66e1a1c4 (patch)
treeaef34a25c7e821cded4f3484aed7431b8a860e18 /include
parent87d0b295402b10c086df3d8d250e668af61a7e51 (diff)
downloadmaster-31e0f0ae-5a9cdef5499b091c8c5c35f7cdc822eb66e1a1c4.tar.gz
master-31e0f0ae-5a9cdef5499b091c8c5c35f7cdc822eb66e1a1c4.tar.bz2
master-31e0f0ae-5a9cdef5499b091c8c5c35f7cdc822eb66e1a1c4.zip
prefer http downloads over svn/git checkouts, remove git dependency
SVN-Revision: 9567
Diffstat (limited to 'include')
-rw-r--r--include/download.mk4
-rw-r--r--include/prereq-build.mk8
2 files changed, 1 insertions, 11 deletions
diff --git a/include/download.mk b/include/download.mk
index 3c7cb7e77b..23f2996ed1 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -39,9 +39,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- @$(if $(CONFIG_LOCALMIRROR),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ) \
- ( $(1) ) \
- $(if $(CONFIG_LOCALMIRROR),, || $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x")
+ @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
endef
define DownloadMethod/svn
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 9b77a1baf7..1e448d393f 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -119,14 +119,6 @@ $(eval $(call Require,gnutar, \
Please install GNU tar. \
))
-define Require/git
- which git-clone
-endef
-
-$(eval $(call Require,git, \
- Please install git. \
-))
-
$(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))