summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /include
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadmaster-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
master-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
master-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk3
-rw-r--r--include/kernel.mk4
-rw-r--r--include/toplevel.mk2
3 files changed, 5 insertions, 4 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 0d3b40e16f..69e602aded 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -110,7 +110,8 @@ define BuildKernel
ifeq ($(DUMP),1)
dumpinfo:
- @echo 'Target: $(BOARD)-$(KERNEL)'
+ @echo 'Target: $(BOARD)'
+ @echo 'Target-Kernel: $(KERNEL)'
@echo 'Target-Name: $(BOARDNAME) [$(KERNEL)]'
@echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'
@echo 'Target-Arch: $(ARCH)'
diff --git a/include/kernel.mk b/include/kernel.mk
index a0f256b998..559b37e4a3 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -30,9 +30,9 @@ else
KERNEL_CROSS:=$(TARGET_CROSS)
endif
- PLATFORM_DIR := $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL)
+ PLATFORM_DIR := $(TOPDIR)/target/linux/$(BOARD)
PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
- KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(KERNEL)-$(BOARD)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
+ KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(BOARD)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
MODULES_SUBDIR:=lib/modules/$(LINUX_VERSION)
diff --git a/include/toplevel.mk b/include/toplevel.mk
index e456264221..8faf8e1437 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -122,7 +122,7 @@ distclean:
rm -rf tmp build_dir staging_dir dl .config*
ifeq ($(findstring v,$(DEBUG)),)
- .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target prepare-tmpinfo
+ .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package prepare-tmpinfo
endif
.PHONY: help FORCE
.NOTPARALLEL: