summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 18:17:40 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 18:17:40 +0000
commit484609eeb06618dd2581f93ba57d0023a1f3adee (patch)
tree7f04a17039bdac5a306e1033a79e042b810051dd /include
parent91e5dba2c76d9185cc06c32feb51b8b0d1c310ca (diff)
downloadmaster-31e0f0ae-484609eeb06618dd2581f93ba57d0023a1f3adee.tar.gz
master-31e0f0ae-484609eeb06618dd2581f93ba57d0023a1f3adee.tar.bz2
master-31e0f0ae-484609eeb06618dd2581f93ba57d0023a1f3adee.zip
commit profile support for base-files... patches still need to be done
SVN-Revision: 6465
Diffstat (limited to 'include')
-rw-r--r--include/target.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index bd3ceb955b..6a136a1bee 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -5,6 +5,21 @@
# See /LICENSE for more information.
#
+define AddProfile
+ $(eval $(call Profile/Default))
+ $(eval $(call Profile/$(1)))
+ ifneq ($(ID),)
+ PROFILE:=$(ID)
+ $(ID)_NAME:=$(NAME)
+ $(ID)_PACKAGES:=$(PACKAGES)
+ ifneq ($(KCONFIG),)
+ PROFILE_LIST += \
+ echo '$(ID):'; [ -z '$(NAME)' ] || echo ' $(NAME)'; echo ' Packages: $(PACKAGES)';
+ endif
+ endif
+endef
+
+
include $(TMP_DIR)/.target.mk
ifeq ($(IB),1)