summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2009-03-02 17:42:29 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2009-03-02 17:42:29 +0000
commit47c78e48bd75266e1724ec5d412fb0e04563c231 (patch)
tree756ef2ae37e31f295a8415e1c6125fea19d5f10f /include
parentf9d0fb8a16f4819b7419454ef3adc11fef4cb922 (diff)
downloadmaster-31e0f0ae-47c78e48bd75266e1724ec5d412fb0e04563c231.tar.gz
master-31e0f0ae-47c78e48bd75266e1724ec5d412fb0e04563c231.tar.bz2
master-31e0f0ae-47c78e48bd75266e1724ec5d412fb0e04563c231.zip
don't abort if the operation is failing ( if the board is connected via NFS files might be created by root and can't be changed at this point of time )
SVN-Revision: 14729
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 7de2d6346e..3341f10e50 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -103,9 +103,9 @@ endif
define Image/mkfs/prepare/default
- find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
- find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
- find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+ - find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+ - find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
+ - find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
$(INSTALL_DIR) $(TARGET_DIR)/tmp
chmod 0777 $(TARGET_DIR)/tmp
endef