summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-28 05:52:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-28 05:52:00 +0000
commit41af082667ac750886f29f3f8338d877567b303f (patch)
tree6ddd09bc0cf52c727d1879be1bce62bc8c621ee5 /include
parent41b03c977033244fc27d206dc88ef5e221b6bd75 (diff)
downloadmaster-31e0f0ae-41af082667ac750886f29f3f8338d877567b303f.tar.gz
master-31e0f0ae-41af082667ac750886f29f3f8338d877567b303f.tar.bz2
master-31e0f0ae-41af082667ac750886f29f3f8338d877567b303f.zip
fill in the kernel version info for every target, move the kernel tarball md5sums to a central place
SVN-Revision: 7748
Diffstat (limited to 'include')
-rw-r--r--include/kernel-version.mk19
1 files changed, 15 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index eaac886ebb..9a9f1c8bff 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,13 +3,24 @@
ifeq ($(LINUX_VERSION),)
ifeq ($(KERNEL),2.4)
LINUX_VERSION:=2.4.34
- LINUX_RELEASE:=1
- LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
else
LINUX_VERSION:=2.6.21.5
- LINUX_RELEASE:=1
- LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
endif
endif
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.4.34)
+ LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
+endif
+ifeq ($(LINUX_VERSION),2.6.22-rc6)
+ LINUX_KERNEL_MD5SUM:=37adac36f3928f5e05dd2704c083620d
+endif
+ifeq ($(LINUX_VERSION),2.6.21.5)
+ LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))