summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-27 17:24:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-27 17:24:27 +0000
commit38b513811ca4e4cf929f19cc8abcbb6f72019efd (patch)
tree580777dba2ef1bb0c5c8d3e3a26e739462136d13 /include
parent3203828ce87652193e6d5111a3b97e739fefd0f8 (diff)
downloadmaster-31e0f0ae-38b513811ca4e4cf929f19cc8abcbb6f72019efd.tar.gz
master-31e0f0ae-38b513811ca4e4cf929f19cc8abcbb6f72019efd.tar.bz2
master-31e0f0ae-38b513811ca4e4cf929f19cc8abcbb6f72019efd.zip
fix conditional depends in ipkg control files
SVN-Revision: 13051
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index de9798413d..c5d4916c2c 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -25,7 +25,8 @@ endef
dep_split=$(subst :,$(space),$(1))
dep_confvar=CONFIG_$(word 1,$(call dep_split,$(1)))
dep_val=$(word 2,$(call dep_split,$(1)))
-filter_deps=$(foreach dep,$(1),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
+strip_deps=$(strip $(subst +,,$(filter-out @%,$(1))))
+filter_deps=$(foreach dep,$(call strip_deps,$(1)),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
ifeq ($(DUMP),)
define BuildTarget/ipkg
@@ -47,7 +48,7 @@ ifeq ($(DUMP),)
endif
endif
- IDEPEND_$(1):=$$(call filter_deps,$$(strip $$(DEPENDS)))
+ IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))
$(eval $(call BuildIPKGVariable,$(1),conffiles))
$(eval $(call BuildIPKGVariable,$(1),preinst))