summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-06-07 15:30:59 +0000
committerTim Yardley <lst@openwrt.org>2007-06-07 15:30:59 +0000
commit35d1063a759bf86c75d05994e441dd8cd892660f (patch)
tree487aa7675ef2bfa3d6ba6d361c2347edf9cbc5bc /include
parentc43671dd28717d5f5cb72bdeda8d4204fc57b3bb (diff)
downloadmaster-31e0f0ae-35d1063a759bf86c75d05994e441dd8cd892660f.tar.gz
master-31e0f0ae-35d1063a759bf86c75d05994e441dd8cd892660f.tar.bz2
master-31e0f0ae-35d1063a759bf86c75d05994e441dd8cd892660f.zip
package ipset for use
SVN-Revision: 7517
Diffstat (limited to 'include')
-rw-r--r--include/netfilter.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index a602f9d71f..531f8c7a73 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -88,6 +88,18 @@ IPT_IPSEC-$(CONFIG_IP_NF_MATCH_AH_ESP) += $(P_V4)ipt_ah $(P_V4)ipt_esp
IPT_IPSEC-$(CONFIG_IP_NF_MATCH_AH) += $(P_V4)ipt_ah
IPT_IPSEC-$(CONFIG_NETFILTER_XT_MATCH_ESP) += $(P_XT)xt_esp
+IPT_IPSET-m :=
+IPT_IPSET-$(CONFIG_IP_NF_SET) += $(P_V4)ip_set
+IPT_IPSET-$(CONFIG_IP_NF_MATCH_SET) += $(P_V4)ipt_set
+IPT_IPSET-$(CONFIG_IP_NF_SET_IPMAP) += $(P_V4)ip_set_ipmap
+IPT_IPSET-$(CONFIG_IP_NF_SET_MACIPMAP) += $(P_V4)ip_set_macipmap
+IPT_IPSET-$(CONFIG_IP_NF_SET_PORTMAP) += $(P_V4)ip_set_portmap
+IPT_IPSET-$(CONFIG_IP_NF_SET_IPHASH) += $(P_V4)ip_set_iphash
+IPT_IPSET-$(CONFIG_IP_NF_SET_NETHASH) += $(P_V4)ip_set_nethash
+IPT_IPSET-$(CONFIG_IP_NF_SET_IPPORTHASH) += $(P_V4)ip_set_ipporthash
+IPT_IPSET-$(CONFIG_IP_NF_SET_IPTREE) += $(P_V4)ip_set_iptree
+IPT_IPSET-$(CONFIG_IP_NF_TARGET_SET) += $(P_V4)ipt_SET
+
IPT_NAT-m :=
ifneq ($(NF_KMOD),1)
IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
@@ -139,5 +151,6 @@ IPT_BUILTIN += $(IPT_FILTER-y)
IPT_BUILTIN += $(IPT_IMQ-y)
IPT_BUILTIN += $(IPT_IPOPT-y)
IPT_BUILTIN += $(IPT_IPSEC-y)
+IPT_BUILTIN += $(IPT_IPSET-y)
IPT_BUILTIN += $(IPT_NAT-y)
IPT_BUILTIN += $(IPT_ULOG-y)