summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-05-19 18:05:20 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-05-19 18:07:02 +0200
commit1ea7dba3778562bc85986b21be77af34956e11a0 (patch)
tree63609f9bf022d15779924cfdb015983b0b7da30d /include
parent2c83003143485ae7cccc8776222afe2d9848c24d (diff)
downloadmaster-31e0f0ae-1ea7dba3778562bc85986b21be77af34956e11a0.tar.gz
master-31e0f0ae-1ea7dba3778562bc85986b21be77af34956e11a0.tar.bz2
master-31e0f0ae-1ea7dba3778562bc85986b21be77af34956e11a0.zip
image.mk: fix building ubifs images
A hook for ubifs was left-out in the new image building code. Add it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 48acd32bc6..b07aa90b45 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -73,6 +73,7 @@ fs-types-$(CONFIG_TARGET_ROOTFS_JFFS2) += $(addprefix jffs2-,$(JFFS2_BLOCKSIZE))
fs-types-$(CONFIG_TARGET_ROOTFS_JFFS2_NAND) += $(addprefix jffs2-nand-,$(NAND_BLOCKSIZE))
fs-types-$(CONFIG_TARGET_ROOTFS_EXT4FS) += ext4
fs-types-$(CONFIG_TARGET_ROOTFS_ISO) += iso
+fs-types-$(CONFIG_TARGET_ROOTFS_UBIFS) += ubifs
fs-subtypes-$(CONFIG_TARGET_ROOTFS_JFFS2) += $(addsuffix -raw,$(addprefix jffs2-,$(JFFS2_BLOCKSIZE)))
fs-subtypes-$(CONFIG_TARGET_ROOTFS_CPIOGZ) += cpiogz
fs-subtypes-$(CONFIG_TARGET_ROOTFS_TARGZ) += targz