summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-18 00:11:20 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-18 00:11:20 +0000
commit03ccf4eeb0702d70a81e9d70a1cc0d50ca0448af (patch)
treefdba8a5a439ebe8a7a32398a9f7e45dd7eeb8b41 /include
parentee5b7c28599250ae68d2e421710df10dfea8d77c (diff)
downloadmaster-31e0f0ae-03ccf4eeb0702d70a81e9d70a1cc0d50ca0448af.tar.gz
master-31e0f0ae-03ccf4eeb0702d70a81e9d70a1cc0d50ca0448af.tar.bz2
master-31e0f0ae-03ccf4eeb0702d70a81e9d70a1cc0d50ca0448af.zip
build: set owner root for all files on ubifs creation
When creating an image it makes no sense to have files owned by the uid and gid on the host (and even creates a bug when for example dropbear authorized_keys is included via env/files). Signed-off-by: Joris de Vries <joris@apptrician.nl> SVN-Revision: 38442
Diffstat (limited to 'include')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 729929f9da..c7da0600c3 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -139,6 +139,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
--jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+ --squash-uids \
-o $(KDIR)/root.ubifs \
-d $(TARGET_DIR)
endif