summaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-23 13:09:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-23 13:09:50 +0000
commitc523c81bfedc3bf77e8981b11e8bef7f00fa3f5f (patch)
tree565fa8eb792937b8d46af03de4351c4766ca133c /include/version.mk
parente568a17e9b6baa638b56ee7ba485b073977ce3e4 (diff)
downloadmaster-31e0f0ae-c523c81bfedc3bf77e8981b11e8bef7f00fa3f5f.tar.gz
master-31e0f0ae-c523c81bfedc3bf77e8981b11e8bef7f00fa3f5f.tar.bz2
master-31e0f0ae-c523c81bfedc3bf77e8981b11e8bef7f00fa3f5f.zip
Revert "version.mk: add "%s" placeholder for dotted target.subtarget notation"
This reverts commit d388882dccc1b25575939c3713b3ab394c371fd0. SVN-Revision: 44090
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/version.mk b/include/version.mk
index d4addd608f..c4747f236f 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%s/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -79,7 +79,6 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%R,$(REVISION),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
- -e 's,%s,$(BOARD)$(if $(SUBTARGET),.$(SUBTARGET)),g' \
-e 's,%t,$(VERSION_TAINTS),g' \
-e 's,%M,$(VERSION_MANUFACTURER),g' \
-e 's,%P,$(VERSION_PRODUCT),g' \