summaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-08 12:46:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 12:46:37 +0000
commit90ed8d1b5b641d88a4200daef5c199479e0b03d1 (patch)
treeacfbabf6fcf564efb51b05e808d9ddcc30f5e18d /include/version.mk
parentafff105706cc4906dbeaced0ae2781ae7d8c147b (diff)
downloadmaster-31e0f0ae-90ed8d1b5b641d88a4200daef5c199479e0b03d1.tar.gz
master-31e0f0ae-90ed8d1b5b641d88a4200daef5c199479e0b03d1.tar.bz2
master-31e0f0ae-90ed8d1b5b641d88a4200daef5c199479e0b03d1.zip
version.mk: add "%s" placeholder for dotted target.subtarget notation
Implement "%s" placeholder that expands to either the target name, e.g. "ar71xx" if the subtarget is generic or to target.subtarget, e.g. "ar71xx.nand" is a subtarget is choosen. Also change the default repository url template to use "%s" instead of "%T" to reflect the directory structure used by the buildbot systems. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43871
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/version.mk b/include/version.mk
index c4747f236f..d4addd608f 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%s/packages)
VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -79,6 +79,7 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%R,$(REVISION),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
+ -e 's,%s,$(BOARD)$(if $(SUBTARGET),.$(SUBTARGET)),g' \
-e 's,%t,$(VERSION_TAINTS),g' \
-e 's,%M,$(VERSION_MANUFACTURER),g' \
-e 's,%P,$(VERSION_PRODUCT),g' \