summaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-13 00:31:15 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-13 00:31:15 +0200
commit32a0b8c1045481cd442c82b8b5cbb330f613c7a7 (patch)
tree8da43effb221a9d5a51a55713b675b14c8969fa8 /include/version.mk
parent5170393f8cae3c5acac61bd6ac6e127f9727cee4 (diff)
downloadmaster-31e0f0ae-32a0b8c1045481cd442c82b8b5cbb330f613c7a7.tar.gz
master-31e0f0ae-32a0b8c1045481cd442c82b8b5cbb330f613c7a7.tar.bz2
master-31e0f0ae-32a0b8c1045481cd442c82b8b5cbb330f613c7a7.zip
include/version.mk: rework repository url handling
- Add %A placeholder for substituting the package architecture - Change %U placeholder to refer to the toplevel repository URL - Construct package feed URLs relative to the toplevel one to match new layout Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/version.mk b/include/version.mk
index d8da358d69..15a566b508 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -1,5 +1,6 @@
#
# Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE Project
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -31,7 +32,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots/trunk/%S/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots)
VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),LEDE)
@@ -84,6 +85,7 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%R,$(REVISION),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
+ -e 's,%A,$(ARCH_PACKAGES),g' \
-e 's,%t,$(VERSION_TAINTS),g' \
-e 's,%M,$(VERSION_MANUFACTURER),g' \
-e 's,%m,$(VERSION_MANUFACTURER_URL),g' \