summaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-17 21:12:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-17 21:12:02 +0000
commita4c8d4e3779af3169825c48b6de782a3620304f7 (patch)
tree3fcf61f9734c0d0d52642c145c3a91e7b1ed45c9 /include/verbose.mk
parent2167101c9089b2198d89e7490f8e7a541adb56e6 (diff)
downloadmaster-31e0f0ae-a4c8d4e3779af3169825c48b6de782a3620304f7.tar.gz
master-31e0f0ae-a4c8d4e3779af3169825c48b6de782a3620304f7.tar.bz2
master-31e0f0ae-a4c8d4e3779af3169825c48b6de782a3620304f7.zip
build: make the color of the 'configuration out of sync' warning red to make it harder for users to overlook
SVN-Revision: 36082
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 2e8ace442e..d34f55fc48 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -27,6 +27,7 @@ endif
ifeq ($(IS_TTY),1)
ifneq ($(strip $(NO_COLOR)),1)
_Y:=\\033[33m
+ _R:=\\033[31m
_N:=\\033[m
endif
endif
@@ -36,6 +37,10 @@ ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
printf "$(_Y)%s$(_N)\n" "$(1)" >&8
endef
+ define ERROR_MESSAGE
+ printf "$(_R)%s$(_N)\n" "$(1)" >&8
+ endef
+
ifeq ($(QUIET),1)
ifneq ($(CURDIR),$(TOPDIR))
_DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -58,4 +63,5 @@ else
define MESSAGE
printf "%s\n" "$(1)"
endef
+ ERROR_MESSAGE=$(MESSAGE)
endif