summaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 22:51:49 +0200
committerFelix Fietkau <nbd@openwrt.org>2016-03-20 17:29:15 +0100
commit60c1f0f64d23003a19a07d6b9638542130f6641d (patch)
tree8fb2787f4c49baded97cd55e0c371fe1cffce2b6 /include/verbose.mk
parentd58a09110ccfa95f06c983fe796806f2e035c9d2 (diff)
parentb3ce218b51746d3a576221ea542facf3a1703ab2 (diff)
downloadmaster-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.gz
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.bz2
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.zip
finally move buildroot-ng to trunk
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
new file mode 100644
index 0000000000..34568a31f8
--- /dev/null
+++ b/include/verbose.mk
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id:$
+
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
+
+ifndef KBUILD_VERBOSE
+ KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+ KBUILD_VERBOSE:=$(V)
+endif
+
+ifneq ($(shell tty -s <&3 || echo x),x)
+ _Y:="\\33[33m"# yellow
+ _N:="\\33[m"# normal
+endif
+
+ifneq ($(KBUILD_VERBOSE),99)
+ ifeq ($(QUIET),1)
+ $(MAKECMDGOALS): trace
+ trace: FORCE
+ @[ -f "$(MAKECMDGOALS)" ] || { \
+ [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
+ echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
+ }
+ else
+ export QUIET:=1
+ ifeq ($(KBUILD_VERBOSE),0)
+ MAKE:=&>/dev/null $(MAKE)
+ endif
+ MAKE:=cmd() { $(MAKE) $$* || { echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+ endif
+
+ .SILENT: $(MAKECMDGOALS)
+endif