summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-04 16:27:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-04 16:27:11 +0000
commitbc60eb3610c458c103576ef9bbceee9abcef2922 (patch)
treed310993916c4c0ce18b1a2891dea55dd190c9fb6 /include/unpack.mk
parentd14f611eb1f7dc25905f639366e2604444aa1804 (diff)
downloadmaster-31e0f0ae-bc60eb3610c458c103576ef9bbceee9abcef2922.tar.gz
master-31e0f0ae-bc60eb3610c458c103576ef9bbceee9abcef2922.tar.bz2
master-31e0f0ae-bc60eb3610c458c103576ef9bbceee9abcef2922.zip
add a crlf workaround similar to the one from freewrt
SVN-Revision: 6507
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index e533476b52..7813e3b3d3 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -17,4 +17,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
else
# try to autodetect file type
endif
+ ifneq ($(strip $(CRLF_WORKAROUND)),)
+ PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ endif
endif