summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 18:10:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 18:10:05 +0000
commitaa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d (patch)
tree5e0e39f175532ad6e626f77994a14c87013e35cc /include/unpack.mk
parentbc6fcb0067e2af16337cd3144c4c5ab532f09ac0 (diff)
downloadmaster-31e0f0ae-aa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d.tar.gz
master-31e0f0ae-aa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d.tar.bz2
master-31e0f0ae-aa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d.zip
allow concurrent use of host-build.mk and package.mk as well as their templates
SVN-Revision: 14621
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index ddd5fd11fe..ae8cdecb27 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -17,7 +17,7 @@ UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
ifeq ($(PKG_SOURCE),)
PKG_UNPACK ?= true
endif
-ifeq ($(strip $(PKG_UNPACK))$(strip $(HOST_UNPACK)),)
+ifeq ($(strip $(UNPACK_CMD)),)
ifeq ($(strip $(PKG_CAT)),)
# try to autodetect file type
EXT:=$(call ext,$(PKG_SOURCE))
@@ -63,6 +63,10 @@ ifeq ($(strip $(PKG_UNPACK))$(strip $(HOST_UNPACK)),)
else
CRLF_CMD :=
endif
+endif
+ifdef PKG_BUILD_DIR
PKG_UNPACK := $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+endif
+ifdef HOST_BUILD_DIR
HOST_UNPACK := $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif