summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
commita9136c0892fa5fa1627c2502d309eeb8cda187f8 (patch)
tree626476203a2fc0de4f74dd79615b0f30a850401c /include/unpack.mk
parentcaf173f8693cb0ec6a4bf9755caa01482c01f92b (diff)
downloadmaster-31e0f0ae-a9136c0892fa5fa1627c2502d309eeb8cda187f8.tar.gz
master-31e0f0ae-a9136c0892fa5fa1627c2502d309eeb8cda187f8.tar.bz2
master-31e0f0ae-a9136c0892fa5fa1627c2502d309eeb8cda187f8.zip
speed up the build system by including include/shell.sh on shell commands only where necessary
SVN-Revision: 22720
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 0151675777..2d35863095 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -71,10 +71,10 @@ ifeq ($(strip $(UNPACK_CMD)),)
endif
ifdef PKG_BUILD_DIR
- PKG_UNPACK ?= $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+ PKG_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
endif
ifdef HOST_BUILD_DIR
- HOST_UNPACK ?= $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
+ HOST_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif
endif # PKG_SOURCE