summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commit7eb15898755be46e94078faffdacd8c9b0ce66cd (patch)
tree89dc171f7b7c646be5a38ca7d7b99e1be24fa61f /include/unpack.mk
parent6ccc1c8e3c9ad0ac95c728573c300264943d8338 (diff)
downloadmaster-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.gz
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.bz2
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.zip
build system refactoring in preparation for allowing packages to do host-build steps
SVN-Revision: 14610
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk36
1 files changed, 20 insertions, 16 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 9b68e5dea3..ddd5fd11fe 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -11,13 +11,13 @@ ifneq ($(HOST_OS),Linux)
else
HOST_TAR:=$(TAR)
endif
-TAR_CMD:=$(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
-UNZIP_CMD:=unzip -d $(PKG_BUILD_DIR)/.. $(DL_DIR)/$(PKG_SOURCE)
+TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
+UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
ifeq ($(PKG_SOURCE),)
PKG_UNPACK ?= true
endif
-ifeq ($(strip $(PKG_UNPACK)),)
+ifeq ($(strip $(PKG_UNPACK))$(strip $(HOST_UNPACK)),)
ifeq ($(strip $(PKG_CAT)),)
# try to autodetect file type
EXT:=$(call ext,$(PKG_SOURCE))
@@ -25,40 +25,44 @@ ifeq ($(strip $(PKG_UNPACK)),)
ifeq ($(filter gz tgz,$(EXT)),$(EXT))
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
- UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
- endif
+ DECOMPRESS_CMD:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
+ endif
ifeq ($(filter bzip2 bz2 bz tbz2 tbz,$(EXT)),$(EXT))
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
- UNPACK:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
+ DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
endif
ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
EXT:=tar
endif
- UNPACK ?= cat $(DL_DIR)/$(PKG_SOURCE) |
+ DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |
ifeq ($(EXT),tar)
- PKG_UNPACK:=$(UNPACK) $(TAR_CMD)
+ UNPACK_CMD=$(DECOMPRESS_CMD) $(TAR_CMD)
endif
ifeq ($(EXT),cpio)
- PKG_UNPACK:=$(UNPACK) (cd $(PKG_BUILD_DIR)/..; cpio -i -d)
+ UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; cpio -i -d)
endif
ifeq ($(EXT),zip)
- PKG_UNPACK:=$(UNZIP_CMD)
+ UNPACK_CMD=$(UNZIP_CMD)
endif
endif
-
+
# compatibility code for packages that set PKG_CAT
- ifeq ($(strip $(PKG_UNPACK)),)
+ ifeq ($(strip $(UNPACK_CMD)),)
# use existing PKG_CAT
- PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+ UNPACK_CMD=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
ifeq ($(PKG_CAT),unzip)
- PKG_UNPACK:=$(UNZIP_CMD)
+ UNPACK_CMD=$(UNZIP_CMD)
endif
# replace zcat with $(ZCAT), because some system don't support it properly
ifeq ($(PKG_CAT),zcat)
- PKG_UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+ UNPACK_CMD=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
endif
endif
ifneq ($(strip $(CRLF_WORKAROUND)),)
- PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ CRLF_CMD := && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ else
+ CRLF_CMD :=
endif
+ PKG_UNPACK := $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+ HOST_UNPACK := $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif