summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 13:04:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 13:04:50 +0000
commit794114c706f1a4e4c4b1d6fcd7ccdc8b39533d91 (patch)
treefcefbdcd68e06463a555a2de53760d046acbb5a6 /include/unpack.mk
parent5f05cf26ee5760df67732ef75e9205aba2ac788e (diff)
downloadmaster-31e0f0ae-794114c706f1a4e4c4b1d6fcd7ccdc8b39533d91.tar.gz
master-31e0f0ae-794114c706f1a4e4c4b1d6fcd7ccdc8b39533d91.tar.bz2
master-31e0f0ae-794114c706f1a4e4c4b1d6fcd7ccdc8b39533d91.zip
fix mistakes in unpack change
SVN-Revision: 5077
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 6449981c1b..52764e492e 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -1,13 +1,13 @@
ifeq ($(strip $(PKG_UNPACK)),)
ifneq ($(strip $(PKG_CAT)),)
# use existing PKG_CAT
- UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
ifeq ($(PKG_CAT),unzip)
- UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ PKG_UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
endif
# replace zcat with $(ZCAT), because some system have it as gzcat
ifeq ($(PKG_CAT),zcat)
- UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ PKG_UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
endif
else
# try to autodetect file type