summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 18:27:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 18:27:53 +0000
commit610e45ae5c6ce47452cee2d7bd13900f7ce4f6d1 (patch)
tree67a9abd40b961d32045fc4008d15a742cd707bff /include/unpack.mk
parent25d318e815d06a829354f84d0d8e4e206473123c (diff)
downloadmaster-31e0f0ae-610e45ae5c6ce47452cee2d7bd13900f7ce4f6d1.tar.gz
master-31e0f0ae-610e45ae5c6ce47452cee2d7bd13900f7ce4f6d1.tar.bz2
master-31e0f0ae-610e45ae5c6ce47452cee2d7bd13900f7ce4f6d1.zip
only define unpack templates if PKG_SOURCE is set
SVN-Revision: 14623
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index ae8cdecb27..e2810944e8 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -16,7 +16,8 @@ UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
ifeq ($(PKG_SOURCE),)
PKG_UNPACK ?= true
-endif
+else
+
ifeq ($(strip $(UNPACK_CMD)),)
ifeq ($(strip $(PKG_CAT)),)
# try to autodetect file type
@@ -64,9 +65,13 @@ ifeq ($(strip $(UNPACK_CMD)),)
CRLF_CMD :=
endif
endif
+
ifdef PKG_BUILD_DIR
PKG_UNPACK := $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
endif
ifdef HOST_BUILD_DIR
HOST_UNPACK := $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif
+
+endif # PKG_SOURCE
+