summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-11 19:07:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-11 19:07:12 +0000
commit5605b82835d762cac910dd640ade13f8c4a3668e (patch)
tree186401085bd67192664ba7c6d84b7f1144f02207 /include/unpack.mk
parent76722ae538e879972f9a2bcfbd31d6c7fc3d4163 (diff)
downloadmaster-31e0f0ae-5605b82835d762cac910dd640ade13f8c4a3668e.tar.gz
master-31e0f0ae-5605b82835d762cac910dd640ade13f8c4a3668e.tar.bz2
master-31e0f0ae-5605b82835d762cac910dd640ade13f8c4a3668e.zip
fix unpacking of .zip files
SVN-Revision: 6083
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 94124e9ec6..e533476b52 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -8,7 +8,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
# use existing PKG_CAT
PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
ifeq ($(PKG_CAT),unzip)
- PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/.. $(DL_DIR)/$(PKG_SOURCE)
endif
# replace zcat with $(ZCAT), because some system have it as gzcat
ifeq ($(PKG_CAT),zcat)