summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
commit0d9ddef0e843133bd0cebdbfe141486fee4a6db8 (patch)
tree8aa331ac11110222623f5bf881856433d0b71682 /include/unpack.mk
parentfdbd2f0907990c720505e4b3a1b18d1c470db7c8 (diff)
downloadmaster-31e0f0ae-0d9ddef0e843133bd0cebdbfe141486fee4a6db8.tar.gz
master-31e0f0ae-0d9ddef0e843133bd0cebdbfe141486fee4a6db8.tar.bz2
master-31e0f0ae-0d9ddef0e843133bd0cebdbfe141486fee4a6db8.zip
move common unpacking code to unpack.mk, replace zcat with $(ZCAT) for systems that use gzcat instead
SVN-Revision: 5070
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
new file mode 100644
index 0000000000..6449981c1b
--- /dev/null
+++ b/include/unpack.mk
@@ -0,0 +1,15 @@
+ifeq ($(strip $(PKG_UNPACK)),)
+ ifneq ($(strip $(PKG_CAT)),)
+ # use existing PKG_CAT
+ UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ ifeq ($(PKG_CAT),unzip)
+ UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ endif
+ # replace zcat with $(ZCAT), because some system have it as gzcat
+ ifeq ($(PKG_CAT),zcat)
+ UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ endif
+ else
+ # try to autodetect file type
+ endif
+endif