summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:03 +0000
commit00bcebeb4cabcaa630ee940f8bd15d29a563afa6 (patch)
tree352b3dbe658c8be5470d509916d84d39479a834f /include/unpack.mk
parent2ba3e0ebe6b43ce38e54b2c9dac2909ed0ce29d2 (diff)
downloadmaster-31e0f0ae-00bcebeb4cabcaa630ee940f8bd15d29a563afa6.tar.gz
master-31e0f0ae-00bcebeb4cabcaa630ee940f8bd15d29a563afa6.tar.bz2
master-31e0f0ae-00bcebeb4cabcaa630ee940f8bd15d29a563afa6.zip
build: remove check for nonexistant CONFIG_TAR_VERBOSITY variable and move TAR_OPTIONS to unpack.mk
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 39979
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 2d35863095..2b33c4cd8e 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -11,6 +11,8 @@ ifneq ($(HOST_OS),Linux)
else
HOST_TAR:=$(TAR)
endif
+
+TAR_OPTIONS:=-xf -
TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)