summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-10-03 09:49:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-10-03 09:49:24 +0000
commitdea417017edc6717e2662ab97b0af3d0b724d360 (patch)
treed52d504832bed9c3ac0524695f4b8d80d50bca91 /include/toplevel.mk
parentf0ce8d24e61782a552fdd68c803c2b5719a099d9 (diff)
downloadmaster-31e0f0ae-dea417017edc6717e2662ab97b0af3d0b724d360.tar.gz
master-31e0f0ae-dea417017edc6717e2662ab97b0af3d0b724d360.tar.bz2
master-31e0f0ae-dea417017edc6717e2662ab97b0af3d0b724d360.zip
toplevel.mk: drop LD_LIBRARY_PATH overrides
Overriding LD_LIBRARY_PATH for host utilities frequently leads to problems with host executables loading shared libraries from the staging_dir, leading to crashes due to incompatible ABIs. Since most host utilties either embed a proper rpath or are reworked to link statically we do not need the workaround anymore. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 47103
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 70f4691678..0e6c55ae08 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -22,8 +22,6 @@ endif
HOSTCC ?= $(CC)
export RELEASE
export REVISION
-export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
-export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))