summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-06 04:53:14 +0000
committerJohn Crispin <john@openwrt.org>2014-10-06 04:53:14 +0000
commitc22bebf6abb7af2e8ccdb65b3b367768c5f051da (patch)
tree89347ef08394a2608dd65c49f084cba662a8f95e /include/toplevel.mk
parent74397a14cabecb629d0ecee12d9b1dc9d710ff65 (diff)
downloadmaster-31e0f0ae-c22bebf6abb7af2e8ccdb65b3b367768c5f051da.tar.gz
master-31e0f0ae-c22bebf6abb7af2e8ccdb65b3b367768c5f051da.tar.bz2
master-31e0f0ae-c22bebf6abb7af2e8ccdb65b3b367768c5f051da.zip
Fix build when TAR_OPTIONS env variable is set
The build system sets a make variable TAR_OPTIONS to the unpacking command, i.e. "-xf -". Now if an environment variable with the same name is set, the make variable is automatically exported to the environment. The make variable is added to the tar command in the makefile, and tar adds the environment variable. This results in a command like "tar -c /some/dir -xf - -xf -" which of course doesn't work. It is also difficult to spot as the second "-xf -" is not visible on the command line. I suggest this is fixed by unexporting TAR_OPTIONS as I see no use of the evironment variable, and it is changed from the original value anyway. Signed-off-by: Jan Kardell <jan.kardell@telliq.com> SVN-Revision: 42794
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index dcde7e2596..8a21f7eef4 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -43,6 +43,8 @@ unexport LPATH
# make sure that a predefined CFLAGS variable does not disturb packages
export CFLAGS=
+unexport TAR_OPTIONS
+
ifneq ($(shell $(HOSTCC) 2>&1 | grep clang),)
export HOSTCC_REAL?=$(HOSTCC)
export HOSTCC_WRAPPER:=$(TOPDIR)/scripts/clang-gcc-wrapper