summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-16 12:18:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-16 12:18:26 +0000
commita0ced5164a6180de55946565fb4a7237948c93bb (patch)
tree882433a12f5f57a44fe4721ae3662edea8caa8d5 /include/toplevel.mk
parent2705cda81389e84687fb0325d2bf6c8bc2756bee (diff)
downloadmaster-31e0f0ae-a0ced5164a6180de55946565fb4a7237948c93bb.tar.gz
master-31e0f0ae-a0ced5164a6180de55946565fb4a7237948c93bb.tar.bz2
master-31e0f0ae-a0ced5164a6180de55946565fb4a7237948c93bb.zip
build: tell users to do non-paralle builds on errors
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45457
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 33baa86da9..d8651d923b 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -166,6 +166,8 @@ clean dirclean: .config
prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
+WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
+
ifeq ($(SDK),1)
%::
@@ -184,7 +186,10 @@ else
printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
fi \
)
- @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+ @+$(ULIMIT_FIX) $(SUBMAKE) -r $@ $(if $(WARN_PARALLEL_ERROR), || { \
+ printf "$(_R)Build failed - please re-run with -j1 to see the real error message$(_N)\n" >&2; \
+ false; \
+ } )
endif