summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-07-04 11:08:58 +0200
committerJohn Crispin <john@phrozen.org>2016-07-06 09:07:25 +0200
commit5b728074160bb1db064737baf95945ae2e972549 (patch)
tree174ebfa4816bb112054f88117d5f0c031f986a73 /include/toplevel.mk
parentaba6de38d273c68ba5c060c53e971f5fd592af76 (diff)
downloadmaster-31e0f0ae-5b728074160bb1db064737baf95945ae2e972549.tar.gz
master-31e0f0ae-5b728074160bb1db064737baf95945ae2e972549.tar.bz2
master-31e0f0ae-5b728074160bb1db064737baf95945ae2e972549.zip
include/toplevel.mk: fix defconfig when ~/.openwrt/defconfig exists
./scripts/feeds update will reset the .config file if ~/.openwrt/defconfig exists, thus resetting the target to ar71xx. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 581083d912..3844f3cfc1 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -110,7 +110,7 @@ config-clean: FORCE
defconfig: scripts/config/conf prepare-tmpinfo FORCE
touch .config
- @if [ -e $(HOME)/.openwrt/defconfig ]; then cp $(HOME)/.openwrt/defconfig .config; fi
+ @if [ -s .config -a -e $(HOME)/.openwrt/defconfig ]; then cp $(HOME)/.openwrt/defconfig .config; fi
$< --defconfig=.config Config.in
confdefault-y=allyes