summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:09 +0000
commitd3610773a1f0ffd1b36dc4101a88278ec8cfa162 (patch)
tree78db8c8c84ce8ac350f5c7538e9ba7197e604cde /include/toplevel.mk
parent94e528f159e1e2308e93f767c49f788e28c26ddb (diff)
downloadmaster-31e0f0ae-d3610773a1f0ffd1b36dc4101a88278ec8cfa162.tar.gz
master-31e0f0ae-d3610773a1f0ffd1b36dc4101a88278ec8cfa162.tar.bz2
master-31e0f0ae-d3610773a1f0ffd1b36dc4101a88278ec8cfa162.zip
include: test build prereqs before preparing tempinfo
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44270
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index f623e03118..23e832f2b4 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -66,6 +66,7 @@ ULIMIT_FIX=_limit=`ulimit -n`; [ "$$_limit" = "unlimited" -o "$$_limit" -ge 1024
prepare-mk: FORCE ;
prepare-tmpinfo: FORCE
+ @+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
mkdir -p tmp/info
$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f include/scan.mk SCAN_TARGET="packageinfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(TOPDIR)/include/package*.mk $(TOPDIR)/overlay/*/*.mk" SCAN_DEPTH=5 SCAN_EXTRA=""
$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="profiles/*.mk $(TOPDIR)/include/kernel*.mk $(TOPDIR)/include/target.mk" SCAN_DEPTH=2 SCAN_EXTRA="" SCAN_MAKEOPTS="TARGET_BUILD=1"
@@ -157,7 +158,6 @@ clean dirclean: .config
@+$(SUBMAKE) -r $@
prereq:: prepare-tmpinfo .config
- @+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
@+$(NO_TRACE_MAKE) -r -s $@
ifeq ($(SDK),1)