summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:24 +0000
commit830c308cf98f1d4a1516190425429223355f5805 (patch)
tree2d4024e6595d4107a2475a8c8baafa15b1a75ef8 /include/toplevel.mk
parent3d8c8cf3bb3c56d84051de4fcd0c16c6f7cd4e10 (diff)
downloadmaster-31e0f0ae-830c308cf98f1d4a1516190425429223355f5805.tar.gz
master-31e0f0ae-830c308cf98f1d4a1516190425429223355f5805.tar.bz2
master-31e0f0ae-830c308cf98f1d4a1516190425429223355f5805.zip
build: ignore the linux package in the sdk only for generating package data, not for dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48171
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 03c5b1f548..d13a37013c 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -69,6 +69,12 @@ ULIMIT_FIX=_limit=`ulimit -n`; [ "$$_limit" = "unlimited" -o "$$_limit" -ge 1024
prepare-mk: FORCE ;
+ifdef SDK
+ IGNORE_PACKAGES = linux
+endif
+
+_ignore = $(foreach p,$(IGNORE_PACKAGES),--ignore $(p))
+
prepare-tmpinfo: FORCE
@+$(MAKE) -r -s staging_dir/host/.prereq-build $(PREP_MK)
mkdir -p tmp/info
@@ -76,7 +82,7 @@ prepare-tmpinfo: FORCE
$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="profiles/*.mk $(TOPDIR)/include/kernel*.mk $(TOPDIR)/include/target.mk" SCAN_DEPTH=2 SCAN_EXTRA="" SCAN_MAKEOPTS="TARGET_BUILD=1"
for type in package target; do \
f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \
- [ "$$t" -nt "$$f" ] || ./scripts/metadata.pl $${type}_config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
+ [ "$$t" -nt "$$f" ] || ./scripts/metadata.pl $(_ignore) $${type}_config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
done
[ tmp/.config-feeds.in -nt tmp/.packagefeeds ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }