summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-13 06:25:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-13 06:25:54 +0000
commit51996a78f1abc9a57feeb98bf4cad6e8faec05a3 (patch)
tree1e2aac02c0eadeee0856f723ae58c5db5fa52418 /include/toplevel.mk
parent084c9abec3a213f17a9abdf1292e4ecc1cbcd496 (diff)
downloadmaster-31e0f0ae-51996a78f1abc9a57feeb98bf4cad6e8faec05a3.tar.gz
master-31e0f0ae-51996a78f1abc9a57feeb98bf4cad6e8faec05a3.tar.bz2
master-31e0f0ae-51996a78f1abc9a57feeb98bf4cad6e8faec05a3.zip
clean up openwrt version handling, use a separate script that is executed at the beginning of the build process, fix revision checking with git
SVN-Revision: 9723
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk17
1 files changed, 6 insertions, 11 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 040ff51249..63325aa018 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -7,20 +7,15 @@
#
RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
SHELL:=/usr/bin/env bash
-OPENWRTVERSION:=$(RELEASE)
PREP_MK= OPENWRT_BUILD= QUIET=0
+
include $(TOPDIR)/include/verbose.mk
-ifneq ($(VERSION),)
- OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
-else
- REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
- ifneq ($(REV),)
- OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
- endif
-endif
+
+REVISION:=$(shell $(TOPDIR)/scripts/getver.sh)
+OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
+export RELEASE
+export REVISION
export OPENWRTVERSION
export IS_TTY=$(shell tty -s && echo 1 || echo 0)