summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-10 11:17:02 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-10 11:17:02 +0000
commit4685e4f27310d55c20c8062b2b4f782e4b709694 (patch)
treea4b102a9368dd9edc59218db80b9968991492b70 /include/toplevel.mk
parent64e7b41b2e95ac9a417b4fdf144134af20caa66a (diff)
downloadmaster-31e0f0ae-4685e4f27310d55c20c8062b2b4f782e4b709694.tar.gz
master-31e0f0ae-4685e4f27310d55c20c8062b2b4f782e4b709694.tar.bz2
master-31e0f0ae-4685e4f27310d55c20c8062b2b4f782e4b709694.zip
sdk: track files with git and use it to implement proper clean targets
Initialize a Git repository in the SDK and use git reset / git clean to rollback any SDK changes with "make clean" or "make dirclean". This approach is more robust than nuking entire directory trees because some parts of them might have been shipped with the original archive. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43904
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 8a21f7eef4..f623e03118 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -135,7 +135,7 @@ kernel_menuconfig: prepare_kernel_conf
kernel_nconfig: prepare_kernel_conf
$(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
-tmp/.prereq-build: include/prereq-build.mk
+tmp/.prereq-build: $(if $(SDK),.git/config) include/prereq-build.mk
mkdir -p tmp
rm -f tmp/.host.mk
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \