summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:19 +0000
commit1a27d74827b6f1ca494aa8e476d311ba74e82747 (patch)
treee13edde5057a757d291d232157e35771b93c3ab5 /include/toplevel.mk
parentfd53d49f5b8e49cad3a97aae24b779cc4b720006 (diff)
downloadmaster-31e0f0ae-1a27d74827b6f1ca494aa8e476d311ba74e82747.tar.gz
master-31e0f0ae-1a27d74827b6f1ca494aa8e476d311ba74e82747.tar.bz2
master-31e0f0ae-1a27d74827b6f1ca494aa8e476d311ba74e82747.zip
include: remove SDK specific target from toplevel.mk
Instead introduce a generic "make prepare" target which is executed if include/prepare.mk exists. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44329
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 0b8a658c18..67357b033a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -136,13 +136,19 @@ kernel_menuconfig: prepare_kernel_conf
kernel_nconfig: prepare_kernel_conf
$(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
-tmp/.prereq-build: $(if $(SDK),.git/config) include/prereq-build.mk
+tmp/.prereq-build: include/prereq-build.mk
mkdir -p tmp
rm -f tmp/.host.mk
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \
}
+ ifneq ($(realpath $(TOPDIR)/include/prepare.mk),)
+ @$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prepare.mk prepare 2>/dev/null || { \
+ echo "Preparation failed."; \
+ false; \
+ }
+ endif
touch $@
printdb: FORCE