summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
commitf6b57149af3edf52773f9c3abf5e5e0454bcb49c (patch)
tree7606e2550f2bb769a33e8f7f3dae3546c6146603 /include/target.mk
parent08a62d8d8a355e9589106309926a18ffb92a9761 (diff)
downloadmaster-31e0f0ae-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.tar.gz
master-31e0f0ae-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.tar.bz2
master-31e0f0ae-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.zip
FPU type should not interfere with the ABI selection. Also make sure we either do real soft-float or hard-float on ARM, with the right options.
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38943
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 0f3145df59..eca218e0b3 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -232,8 +232,8 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mpcore = -march=armv6k -mtune=mpcore
CPU_CFLAGS_xscale = -march=armv5te -mtune=xscale
ifneq ($(CONFIG_SOFT_FLOAT),)
- CPU_CFLAGS_vfp = -mfpu=vfp -mfloat-abi=softfp
- CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16 -mfloat-abi=softfp
+ CPU_CFLAGS_vfp = -mfpu=vfp
+ CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
endif
endif
ifeq ($(ARCH),powerpc)