summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-18 17:52:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-18 17:52:03 +0000
commite620f4d6f83d457579a6ac53d8659f3171739d18 (patch)
tree34ea05066ab7801d04cada1663602eb236621b24 /include/target.mk
parent018e84f58d3d23d5c1f629843ada5569723b9f00 (diff)
downloadmaster-31e0f0ae-e620f4d6f83d457579a6ac53d8659f3171739d18.tar.gz
master-31e0f0ae-e620f4d6f83d457579a6ac53d8659f3171739d18.tar.bz2
master-31e0f0ae-e620f4d6f83d457579a6ac53d8659f3171739d18.zip
arc: clean-up and move CFLAGS to include/target.mk
Most of currently mentioned CFLAGS in arc770/Makefile are not really required because: [1] "-Os -pipe" are set by default in include/target.mk [2] "-fno-caller-saves" gets enabled via menuconfig as an extra compiler flag for developers So the only one that makes sense is "-matomic" and that one is really essential. Without it many software packges won't build complainin on unresolved atomic ops. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 48326
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index f1292987f2..d8c0212cf8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -263,6 +263,7 @@ ifeq ($(DUMP),1)
endif
ifeq ($(ARCH),arc)
CPU_TYPE ?= arc700
+ CPU_CFLAGS += -matomic
CPU_CFLAGS_arc700 = -marc700
endif
DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))