summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-31 09:30:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-31 09:30:03 +0000
commitd31c1e228516ba0498414c1ca4271082611b1bb2 (patch)
treed31caa61b62bb0789719e1df6512fb75403926ae /include/target.mk
parent93efeef9b3aa4b723da42dfbd69f882c3d721df9 (diff)
downloadmaster-31e0f0ae-d31c1e228516ba0498414c1ca4271082611b1bb2.tar.gz
master-31e0f0ae-d31c1e228516ba0498414c1ca4271082611b1bb2.tar.bz2
master-31e0f0ae-d31c1e228516ba0498414c1ca4271082611b1bb2.zip
target.mk: add optimization flags for MIPS 24Kc.
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 47323
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index f8c0d2386d..798805604c 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -212,6 +212,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mips32 = -mips32 -mtune=mips32
CPU_CFLAGS_mips32r2 = -mips32r2 -mtune=mips32r2
CPU_CFLAGS_mips64 = -mips64 -mtune=mips64 -mabi=64
+ CPU_CFLAGS_24kc = -mips32r2 -mtune=24kc
CPU_CFLAGS_24kec = -mips32r2 -mtune=24kec
CPU_CFLAGS_34kc = -mips32r2 -mtune=34kc
CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc