summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:25 +0000
commitcc43532293de7ef236e43752265ff0e5a6af8261 (patch)
tree21970989a2dd9eac0319137f603b3201cd757780 /include/target.mk
parent20a3814a9cd2d5f73518f65101c3015879e0a92a (diff)
downloadmaster-31e0f0ae-cc43532293de7ef236e43752265ff0e5a6af8261.tar.gz
master-31e0f0ae-cc43532293de7ef236e43752265ff0e5a6af8261.tar.bz2
master-31e0f0ae-cc43532293de7ef236e43752265ff0e5a6af8261.zip
build: optimize target metadata dump
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43019
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk15
1 files changed, 7 insertions, 8 deletions
diff --git a/include/target.mk b/include/target.mk
index f8c2375917..3401f849a5 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -63,8 +63,8 @@ ifndef Profile
define Profile
$(eval $(call Profile/Default))
$(eval $(call Profile/$(1)))
- $(eval $(call shexport,Profile/$(1)/Config))
- $(eval $(call shexport,Profile/$(1)/Description))
+ dumpinfo : $(call shexport,Profile/$(1)/Config)
+ dumpinfo : $(call shexport,Profile/$(1)/Description)
DUMPINFO += \
echo "Target-Profile: $(1)"; \
echo "Target-Profile-Name: $(NAME)"; \
@@ -73,10 +73,10 @@ define Profile
echo "Target-Profile-Kconfig: yes"; \
fi; \
echo "Target-Profile-Config: "; \
- $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Config)"; \
+ echo "$$$$$$$$$(call shvar,Profile/$(1)/Config)"; \
echo "@@"; \
echo "Target-Profile-Description:"; \
- $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
+ echo "$$$$$$$$$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
@@ -104,8 +104,6 @@ else
endif
endif
-$(eval $(call shexport,Target/Description))
-
ifneq ($(TARGET_BUILD)$(if $(DUMP),,1),)
include $(INCLUDE_DIR)/kernel-version.mk
endif
@@ -259,6 +257,7 @@ endif
define BuildTargets/DumpCurrent
.PHONY: dumpinfo
+ dumpinfo : export DESCRIPTION=$$(Target/Description)
dumpinfo:
@echo 'Target: $(TARGETID)'; \
echo 'Target-Board: $(BOARD)'; \
@@ -273,9 +272,9 @@ define BuildTargets/DumpCurrent
echo 'Linux-Version: $(LINUX_VERSION)'; \
echo 'Linux-Release: $(LINUX_RELEASE)'; \
echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
- $(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; ))
+ $(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; )) \
echo 'Target-Description:'; \
- $(SH_FUNC) getvar $(call shvar,Target/Description); \
+ echo "$$$$DESCRIPTION"; \
echo '@@'; \
echo 'Default-Packages: $(DEFAULT_PACKAGES) $(call extra_packages,$(DEFAULT_PACKAGES))'; \
$(DUMPINFO)