summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-01-12 12:27:32 +0000
committerJohn Crispin <john@openwrt.org>2014-01-12 12:27:32 +0000
commit87514999737d9acfd7b17e3ce26dbce41655a20d (patch)
tree5a38b86a4c1223ffe54deaa6066418c19022634d /include/target.mk
parent4282d796ea75b5e99c7e89c727a952f686cccf2c (diff)
downloadmaster-31e0f0ae-87514999737d9acfd7b17e3ce26dbce41655a20d.tar.gz
master-31e0f0ae-87514999737d9acfd7b17e3ce26dbce41655a20d.tar.bz2
master-31e0f0ae-87514999737d9acfd7b17e3ce26dbce41655a20d.zip
Fix build for individual profiles with dashes in names
Config symbols can have regular dashes, e.g. CONFIG_TARGET_ramips_rt305x_UR-336UN=y So no substitution should be performed on the last part of the symbol. Signed-off-by: Paul Fertser <fercerpav@gmail.com> SVN-Revision: 39242
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index eca218e0b3..ccec41f71c 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -76,7 +76,7 @@ define Profile
$(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
- ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
+ ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
PROFILE=$(1)
endif
endef