summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-11 20:13:58 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-11 20:14:00 +0200
commit4a31037a34167a41705de319cdf989a63519debb (patch)
treee6af96df9a1ed4125ca89313559e80f976cd70b0 /include/target.mk
parentb0cf769008bc38f386c977f38f80de0fef098355 (diff)
downloadmaster-31e0f0ae-4a31037a34167a41705de319cdf989a63519debb.tar.gz
master-31e0f0ae-4a31037a34167a41705de319cdf989a63519debb.tar.bz2
master-31e0f0ae-4a31037a34167a41705de319cdf989a63519debb.zip
build: avoid including profiles/*.mk
Generate the active profile name in menuconfig context Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk9
1 files changed, 3 insertions, 6 deletions
diff --git a/include/target.mk b/include/target.mk
index f4342bdbb5..868fe6b375 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -84,9 +84,6 @@ define Profile
echo "$$$$$$$$$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
- ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
- PROFILE=$(1)
- endif
endef
endif
@@ -101,10 +98,10 @@ else
endef
endif
+PROFILE:=$(call qstrip,$(CONFIG_TARGET_PROFILE))
+
ifeq ($(TARGET_BUILD),1)
- $(eval $(call IncludeProfiles))
-else
- ifeq ($(DUMP),)
+ ifneq ($(DUMP),)
$(eval $(call IncludeProfiles))
endif
endif