summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-02-12 15:43:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-02-12 15:43:14 +0000
commit157f56c461d64e51823f2c12049300987bc3ba8b (patch)
tree3f27a7dbfd17670dd5f755e374ca8e4f4497ba3a /include/target.mk
parent16b039f36796471114732bf2fe933884aa7ff352 (diff)
downloadmaster-31e0f0ae-157f56c461d64e51823f2c12049300987bc3ba8b.tar.gz
master-31e0f0ae-157f56c461d64e51823f2c12049300987bc3ba8b.tar.bz2
master-31e0f0ae-157f56c461d64e51823f2c12049300987bc3ba8b.zip
handle "neon" fpu type
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39579
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 20347e9b01..79d52f0b84 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -232,6 +232,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mpcore = -march=armv6k -mtune=mpcore
CPU_CFLAGS_xscale = -march=armv5te -mtune=xscale
ifeq ($(CONFIG_SOFT_FLOAT),)
+ CPU_CFLAGS_neon = -mfpu=neon
CPU_CFLAGS_vfp = -mfpu=vfp
CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
endif