summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-20 09:46:45 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-20 09:46:45 +0000
commitddc57879ec7e2310ff544d5f9cc4bc02d7f07d05 (patch)
tree5de42b2021348aa6ece28b913751c1713a8a2232 /include/target.mk
parent1f666fa4597abc453c0923de99b27a473730ca0c (diff)
downloadmaster-31e0f0ae-ddc57879ec7e2310ff544d5f9cc4bc02d7f07d05.tar.gz
master-31e0f0ae-ddc57879ec7e2310ff544d5f9cc4bc02d7f07d05.tar.bz2
master-31e0f0ae-ddc57879ec7e2310ff544d5f9cc4bc02d7f07d05.zip
add a gpio feature for devices supporting the generic GPIO interface
SVN-Revision: 10879
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 4f10a3db2b..ce842da795 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -126,6 +126,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifneq ($(CONFIG_GENERIC_GPIO),)
+ FEATURES += gpio
+ endif
ifneq ($(CONFIG_PCI),)
FEATURES += pci
endif