summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:38 +0000
commit6117c04c9416b295347fb45c37e430f01df1d0d9 (patch)
tree5495e559b330b53c532b2b51d48ba7a256490e34 /include/target.mk
parent157f44d71818f9c70202f53e604bdda8615fbffb (diff)
downloadmaster-31e0f0ae-6117c04c9416b295347fb45c37e430f01df1d0d9.tar.gz
master-31e0f0ae-6117c04c9416b295347fb45c37e430f01df1d0d9.tar.bz2
master-31e0f0ae-6117c04c9416b295347fb45c37e430f01df1d0d9.zip
remove linux 2.4 specific build system code
SVN-Revision: 21951
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/include/target.mk b/include/target.mk
index 5eb8547cc2..ae20bc9345 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -12,16 +12,11 @@ __target_inc=1
DEVICE_TYPE?=router
# Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg
+DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg udevtrigger hotplug2
# For router targets
DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
DEFAULT_PACKAGES.bootloader:=
-# Additional packages for Linux 2.6
-ifneq ($(KERNEL),2.4)
- DEFAULT_PACKAGES += udevtrigger hotplug2
-endif
-
# Add device specific packages
DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))