summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
commit56164a5815346ed801c1fd8885023f55c19b29ff (patch)
treed5f46ef620e54d7b0ff56c98fed8ad25895d6bb7 /include/target.mk
parent24aedf82810f1abcdd345741ab7a97adea43ad1c (diff)
downloadmaster-31e0f0ae-56164a5815346ed801c1fd8885023f55c19b29ff.tar.gz
master-31e0f0ae-56164a5815346ed801c1fd8885023f55c19b29ff.tar.bz2
master-31e0f0ae-56164a5815346ed801c1fd8885023f55c19b29ff.zip
add a modified version of the mips64 patch from #4603
SVN-Revision: 15249
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 2f62c2a8cd..5484592def 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -155,6 +155,8 @@ ifeq ($(DUMP),1)
DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -funit-at-a-time
DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time
DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
+ DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -funit-at-a-time
+ DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time
DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -funit-at-a-time)