summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-03-25 15:04:44 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-03-25 15:04:44 +0000
commit2bc9d6f6e9e25fccd3fc0ac63413cae925f803cf (patch)
treedefd80fbc333403d5eea41e82869d91914209e83 /include/target.mk
parent141f9e3bbd19068e7ea68a8099b08f857c6d6d61 (diff)
downloadmaster-31e0f0ae-2bc9d6f6e9e25fccd3fc0ac63413cae925f803cf.tar.gz
master-31e0f0ae-2bc9d6f6e9e25fccd3fc0ac63413cae925f803cf.tar.bz2
master-31e0f0ae-2bc9d6f6e9e25fccd3fc0ac63413cae925f803cf.zip
include/target.mk: Only set usb feature flag for a target if there is a HCD
SVN-Revision: 20425
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 61ff2d21aa..5eb8547cc2 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -148,7 +148,9 @@ ifeq ($(DUMP),1)
FEATURES += pcie
endif
ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
- FEATURES += usb
+ ifneq ($(CONFIG_USB_ARCH_HAS_HCD)$(CONFIG_USB_EHCI_HCD),)
+ FEATURES += usb
+ endif
endif
ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
FEATURES += pcmcia