summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 23:36:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 23:36:59 +0000
commit066a009c348602f578bbc37f6b83490b4930d679 (patch)
tree452cb39f52b63bb3d00d35e2746f4cf93dafaf6d /include/target.mk
parentcc04f0502f503c9d1cca92aed1e861c271c28ff3 (diff)
downloadmaster-31e0f0ae-066a009c348602f578bbc37f6b83490b4930d679.tar.gz
master-31e0f0ae-066a009c348602f578bbc37f6b83490b4930d679.tar.bz2
master-31e0f0ae-066a009c348602f578bbc37f6b83490b4930d679.zip
final fix for the profile selection
SVN-Revision: 6474
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index d0f7b9bc2b..1718a869c1 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -5,14 +5,16 @@
# See /LICENSE for more information.
#
-include $(TMP_DIR)/.target.mk
define AddProfile
- ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
- PROFILE=$(1)
+ ifeq ($(CONFIG_LINUX_$(1)),y)
+ $(call Profile/$(1))
+ PROFILE=$$(ID)
endif
endef
+include $(TMP_DIR)/.target.mk
+
ifeq ($(IB),1)
$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
$(CP) $< $@