summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 21:14:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 21:14:08 +0000
commitd7f2cb164209468046dc093a35d4f10c7350944b (patch)
treef5c562b565716be8d74e1660634d5dd8779ae81f /include/subdir.mk
parenta7b635f07546eadbdd8c6dc0cfd623290622f026 (diff)
downloadmaster-31e0f0ae-d7f2cb164209468046dc093a35d4f10c7350944b.tar.gz
master-31e0f0ae-d7f2cb164209468046dc093a35d4f10c7350944b.tar.bz2
master-31e0f0ae-d7f2cb164209468046dc093a35d4f10c7350944b.zip
next round of cleanup, convert target/ - make -j works now ;)
SVN-Revision: 8242
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index da37573c78..4348c7b93d 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -24,7 +24,8 @@ define subdir
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
- @+$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+ +$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+ $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
# legacy targets
$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
@@ -36,12 +37,18 @@ endef
# Parameters: <subdir> <name> <target>
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
- $(call rdep,$(1),$$($(1)/stamp-$(3)),)
+ $(if __rdep_$(1),,
+ $(call rdep,$(1),$$($(1)/stamp-$(3)),)
+ __rdep_$(1):=1
+ )
$$($(1)/stamp-$(3)):
- @+$(MAKE) $(1)/$(3)
+ @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))
+
+ $$(if $(call debug,$(1),v),,.SILENT: $$($(1)/stamp-$(3)))
+
.PRECIOUS: $$($(1)/stamp-$(3)) # work around a make bug
$(1)//clean:=$(1)/stamp-$(3)/clean