summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
commitd475d94aab91230bd837a9d4d7ea58c3829e1c20 (patch)
tree2e9dfad5563ba1e590208621984e77cd6853b9af /include/subdir.mk
parentec70a7a19f472cca7f657ba96f3fcdeb2dd90198 (diff)
downloadmaster-31e0f0ae-d475d94aab91230bd837a9d4d7ea58c3829e1c20.tar.gz
master-31e0f0ae-d475d94aab91230bd837a9d4d7ea58c3829e1c20.tar.bz2
master-31e0f0ae-d475d94aab91230bd837a9d4d7ea58c3829e1c20.zip
avoid rdep in the top level make process (subdir.mk) - it leaks too much memory and increases the startup time for regular make commands. timestamp.pl is more lightweight here
SVN-Revision: 8533
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 217d6bc376..0a3eff307e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -37,13 +37,9 @@ endef
# Parameters: <subdir> <name> <target>
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
- $(if $(__rdep_$(1)),,
- $(call rdep,$(1),$$($(1)/stamp-$(3)),)
- __rdep_$(1):=1
- )
-
- $$($(1)/stamp-$(3)):
- @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+ $$($(1)/stamp-$(3)): $(TMP_DIR)/.build
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))