summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2009-05-28 16:30:04 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2009-05-28 16:30:04 +0000
commitc4d7af70948fb173132c4cd632421547d95bf305 (patch)
treee9037bc7ddf252f96ce8c6bd58c79ff39c4b212a /include/subdir.mk
parent72e25b07b8cacd76265f39db048f740407663ddf (diff)
downloadmaster-31e0f0ae-c4d7af70948fb173132c4cd632421547d95bf305.tar.gz
master-31e0f0ae-c4d7af70948fb173132c4cd632421547d95bf305.tar.bz2
master-31e0f0ae-c4d7af70948fb173132c4cd632421547d95bf305.zip
added BUILD_LOG_DIR variable, make clean will delete the ./logs dir
SVN-Revision: 16148
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 26a8626524..be8c308205 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -34,8 +34,8 @@ define subdir
$(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(btype)/$(target): $(1)/$(bd)/$(btype)/$(target)))
)
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
- $(if $(BUILD_LOG),@mkdir -p $(TOPDIR)/logs/$(1)/$(bd))
- +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(TOPDIR)/logs/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
+ $(if $(BUILD_LOG),@mkdir -p $(BUILD_LOG_DIR)/$(1)/$(bd))
+ +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
# legacy targets