summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-08 17:15:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-08 17:15:45 +0000
commitb544fd922a04fee54b2a2a9c8739b022e0e95dfb (patch)
treec60029720ced8786321862041bb81670343ed694 /include/subdir.mk
parentf71fa7d646011d9ed8040d816f3aaf8e7d5bfdcf (diff)
downloadmaster-31e0f0ae-b544fd922a04fee54b2a2a9c8739b022e0e95dfb.tar.gz
master-31e0f0ae-b544fd922a04fee54b2a2a9c8739b022e0e95dfb.tar.bz2
master-31e0f0ae-b544fd922a04fee54b2a2a9c8739b022e0e95dfb.zip
tools: fix stampfile dependency handling when the list of build dirs changes (#15186)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 39845
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index a2adff2a59..a08c94247e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -57,7 +57,7 @@ endef
ifndef DUMP_TARGET_DB
# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
define stampfile
- $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+ $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(5)
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $(if $(QUIET),--no-print-directory) $$($(1)/flags-$(3)) $(1)/$(3)